Security advisories published on 22–23 October identify a memory-corruption flaw in the Brotli decoder, a component used to decompress web content. CVE-2026-111497 can allow a crafted compressed stream to cause a crash, disclose memory or potentially execute code. The affected application must process the attacker-controlled stream.[1][2][3]
Envoy’s advisory credits OpenAI Security Research. The practical consequence extends beyond the discovery team: applications and packages that include the decoder need their own updates. An upstream library fix reaches users only when it is incorporated into the software they actually run.[2]
Why a malformed compressed file matters
Brotli decoding turns compressed bytes back into usable content. Because those bytes can arrive from an untrusted network source, the decoder must handle malformed streams safely. The reported out-of-bounds write can corrupt adjacent decoder state; whether that becomes reliable code execution depends on the surrounding application and its protections.[1][3]
Upstream corrected releases include Brotli 1.0.10, 1.1.1 and 1.2.1, reflecting fixes on different branches. Package-specific versions differ: the Python Brotli package is patched in 1.2.1 and brotlicffi in 1.2.1.0. A product’s own advisory is therefore the appropriate guide to its supported update.[1]
Published package and proxy fixes
| Software | Fixed releases | Relevant scope |
|---|---|---|
| Python Brotli | 1.2.1 | Advisory lists affected versions ≥1.0.3 and <1.2.1 |
| Python brotlicffi | 1.2.1.0 | Advisory lists affected versions ≥1.0.3 and <1.2.1.0 |
| Envoy | 1.40.0; 1.39.3; 1.38.6; 1.37.8; 1.36.12 | Deployments with Brotli decompression configured |
Severity depends on the deployment
Envoy rates the issue Critical with a CVSS v4 score of 9.2. Red Hat rates it Important, citing hardening and the difficulty of turning the corruption into reliable code execution; its assessment says no public reliable remote-code-execution proof of concept was available. The different assessments reflect attack conditions and protections, while both identify an update-worthy flaw.[2][3]
The relevant inventory includes products that bundle Brotli as well as direct library dependencies. Envoy explicitly limits the affected deployment configuration to an enabled Brotli decompressor. Matching the installed product, its configuration and its supported patched release connects a vulnerability notice to an actionable maintenance task.[1][2]
The downstream work after discovery
A disclosed decoder defect creates a coordination problem across maintainers, application developers and operators. Each must determine where the code is embedded and how a corrected release reaches users. Automated discovery can expose the first failure quickly; dependency tracking and update channels determine how broadly the fix takes effect.[1][2]
The patch has to reach the decoder used by the running service, including copies bundled inside applications. For Envoy, the advisory makes the immediate scope explicit: deployments with Brotli decompression configured.[1][2]
Sources & further reading
- A buffer overflow vulnerability in the Brotli decoder — CVE-2026-111497 GitHub Advisory Database · 22 Oct 2026 · Accessed 26 Oct 2026
- Out-of-Bounds Write in Brotli Decompressor Envoy / GitHub Security Advisory · 23 Oct 2026 · Accessed 26 Oct 2026
- CVE-2026-111497: Red Hat security assessment Red Hat · 22 Oct 2026 · Accessed 26 Oct 2026